See this article for more about minimum internet connection requirements

Accessing Velpic via a Desktop Computer

Operating Systems

Velpic supports the following operating systems

  • Microsoft Windows 7 (or higher)
  • OSX (Last two major releases)Most Linux Distributions

Browsers

The following browsers and their versions are supported. This information will get updated periodically.

  • Mozilla Firefox*
  • Google Chrome*
  • Safari*
  • Microsoft Edge*
  • Internet Explorer 11+

 * Given the nature of the release policy that these browsers follow, We support the last 2 major versions of Firefox, Chrome, Safari and Edge.

Browser Settings - Please ensure you have JavaScript, Cookies and LocalStorage enabled to Access Velpic

Accessing the Velpic applications on a mobile device

Learn and Supervisor Apps

iOS - Minimum is iOS 8
Android - Minimum supported is 4.1.x (jelly bean) api level 16+

Learn VR

The Velpic Learn VR app uses modern technologies to stream VR experiences to mobile devices.  Therefore, there is a higher minimum requirement for mobile devices wishing to access VR content.

iOS - minimum is iOS 8
Android - minimum supported is 6.0 (Marshmallow) api level 23+,

Did this answer your question?